Supported Operating Systems for Wickr:


Windows 10

MacOS 10.12 or later

For use with any Linux distro supported by snapcraft

iOS 11.0 and greater

Android 5.0 or higher


https://support.wickr.com/hc/en-us/articles/115004914067-Wickr-Device-Compatibility


This document below will give you bandwidth requirements:

https://support.wickr.com/hc/en-us/articles/360052501653-Bandwidth-QoS-Requirements-for-Voice-and-Video-Calls